Anmeldung

DosGameBros
14.05.2018, 20:52
Guten Abend,

seit einigen Tagen veruche ich den BMW 3.0 CSL Hommage zu konvertieren. [1|2] Bis jetzt ist es ganz gut gelungen, aus dem ZModeler als .3ds Datei exportiert, in Blender importiert, etwas angepasst und dort dann wieder als .3ds oder .obj. ausgegeben (.lwo - Export gibt's bei 2.79 wohl nicht mehr - konnte auch nur dem Import in den Einstellungen aktivieren...).
Immer wenn ich das Ganze dann im MTKit impotieren wollte, war der Wagen spiegelverkehrt. [3] Hab ein bisschen gegoogelt und hier auf EG geguckt -> Fahrzeug flippen. Hab's gemacht - in Blender sah es wie immer super aus - sobald ich die geflippte Version im MTKit importieren will sieht das ganze schrecklich aus...[4]

Ich hoffe, dass mir da jemand von Euch hier etwas weiterhelfen kann.

Mit freundlichen Grüßen
DGB
thecloser_
14.05.2018, 21:25
Du verwechselst hier zwei Sachen miteinander.

Wenn das Auto gespiegelt ist, muss du es nicht flippen, sonst erhälst du so hässliche ergebnisse wie auf Bild 4. Die Spiegelung dürfte damit eigentlich auch nicht behoben sein (?). Ich erspar mir lange Erklärungen und komme zur Lösung:

Folgendes kann ich dir anbieten:

Hier siehst du, welche Einstellungen du am besten in Blender machst, damit es ähnlich dem MTKit aussieht.

Hier siehst du, welche Einstellungen für den OBJ-Export getroffen werden müssen. Sollte das dann nicht funktionieren, gibt es unter den exportierten Objekten ein Objekt ohne Mapping (was der MTKit nicht mag)

1 mal bearbeitet, zuletzt von thecloser_ am 14.05.2018 21:26
Nix gegen Baguette, aber...

https://abload.de/img/signature_newbuyas.jpg
1 Benutzer(n) gefällt dieser Beitrag
DosGameBros
15.05.2018, 17:46
Danke für die Antwort. Flippen hab ich wohl falsch vertanden - weiß jetzt allerdings was das ist. Die Einstellungen in Blender hab ich ebenfalls angepasst.

So wie es aussieht hab ich wohl Objekte ohne Mapping in meinem Modell, sodass das exportieren als .obj nicht gespiegelt ist, allerding absolut schlimm aussieht. Beim .3ds - Export siehts allerdings nach wie vor aus wie vorher...
Da ich nicht alle Objekte neu mappen möchte... - ist es irgendwie möglich den Wagen so zu spiegeln, dass es beim .3ds - Export keine Probleme gibt?
thecloser_
15.05.2018, 19:19
3ds ist generell nicht zu empfehlen, da das Dateiformat in meinen Augen Schrott ist.

Du vermischt schon wieder einiges wink

Ein Mapping beseitigt das Spiegeln auch nicht - ein Mapping wird (eigentlich) nur für Texturen gebraucht.
Spiegeln kannst du dein Modell (was du eig nicht brauchst, weil es in Blender ja richtig angezeigt wird) mittels STRG+M+X (für Spiegelung an der X-Achse). Danach musst du dein Modell allerdings neu flippen^^

Für die Objekte, welche kein Mapping (und später auch keine Textur) haben, kannst du auch ein Pseudomapping erstellen, einfach im EditMode U-Unwrap drücken und fertig. Mehr musst du dabei gar nicht machen.
Nix gegen Baguette, aber...

https://abload.de/img/signature_newbuyas.jpg
DosGameBros
15.05.2018, 20:12
Nochmals Danke für Deine Antwort.
Wenn ich das ganze als .obj exportiere, ist das Modell komplett schwarz / dunkelgrau im MTKit.
Hab das auch mit dem Pseudomapping versucht, hat allerdings nichts am Erscheinungsbild im MTKit geändert.

Wenn ich das ganze spiegle (für .3ds) und anschließend neu flippe, siehts deutlich besser aus als vorher... allerdings wollen die Türen da nicht. Ich habe das Gefühl, dass mein Fehler schon beim Export aus dem zModeler liegt...

Gibt es vielleicht in Lightwave eine Möglichkeit Objekte sauber zu spiegeln... bzw. in Lightwave hab ich das Problem, dass das MTKit die Dateien nicht schluckt da die von der 2018er-Version wohl zu neu sind...
thecloser_
15.05.2018, 20:19
Was genau ist das Problem, wenn das modell komplett schwarz im MTKit ist? Du musst die MTL ja eh neu anpassen.
Kleiner Tipp: Du darfst die OBJ nie wie deine MOX benennen (d.h. Abrevia.mox und Abrevia.obj), da beide unterschiedliche MTLs verwenden und es so zu Fehlern kommt.

Du hast exakt das Problem an 3ds erkannt. Das Modell ist mit relativen Koordinaten abgespeichert, was allerdingt nicht nur dem MTKit probleme bereitet...

Nochmal: Wenn in Blender alles passt, liegt der Fehler an den Dateien dazwischen
Nix gegen Baguette, aber...

https://abload.de/img/signature_newbuyas.jpg
1 Benutzer(n) gefällt dieser Beitrag
Steinmetz Omi
17.05.2018, 00:57
Das mit dem exportieren aus Zmodeler bitte nur als OBJ da wie thecloser schon beschrieben hatte , das es zu Koordinaten Problemen in 3ds kommt. Aber das Mtkit hat ein anderes Problem , die Fahrzeuge müssen in Blender gedreht werden.
ZMOD -> .obj -> blender -> drehen mit 3 r x -90 Enter 7 r y 90 Enter -> Export 3ds -> import in Mtkit.

Habe die Ehre
De Omi
http://www11.pic-upload.de/img/16210883/AUDISignatur-2.jpg
1 Benutzer(n) gefällt dieser Beitrag
DosGameBros
19.05.2018, 12:19
Vielen Dank für die Hilfe!
Auch einen großen Dank an thecloser! Ich hab's endlich geschafft - der BMW ist korrekt im MTKit.
Nach dem Urlaub werde ich mich dann drum kümmern, dass der Wagen fertig wird ;-)

Nochmals vielen Dank

Mit freundlichen Grüßen
DGB
Um ein Thema zu eröffnen und Beiträge zu schreiben, musst du registriert und angemeldet sein!

registrieren
anmelden

Battle Gewinner